Go down
avatar
vantablack3d
medic
Posts : 2
Reputation : 0
Join date : 2019-09-08

[OPEN LOW] Frame Skip every 8 seconds Empty [OPEN LOW] Frame Skip every 8 seconds

on Sun Sep 08, 2019 12:53 pm
Hello,

I have an odd issue that has arisen recently. I have been away from the game for a while and have come back after learning of the rotate camera patch and upcoming changes to manual patient care so spun the game up again to find that every 8 seconds, it seems to "skip" a frame. I can watch people walking down the sidewalk and every 8 seconds without fail, they will appear to freeze for a nano second.

This is happening on both my PC and laptop, both of which I have never seen this previously. There are no mods present.

I'm unsure what other type of information I can provide but please let me know if I can supply anything that may assist in troubleshooting this as it's unplayable with that constant skip.

Thanks.
avatar
MedJet
attending
Posts : 49
Reputation : -8
Join date : 2018-11-21

[OPEN LOW] Frame Skip every 8 seconds Empty Re: [OPEN LOW] Frame Skip every 8 seconds

on Sun Sep 08, 2019 9:23 pm
Yeah, i've noticed the skip too...very subtle but persistent.
jan.oxymoron
jan.oxymoron
developer
Posts : 1288
Reputation : 217
Join date : 2018-03-23

[OPEN LOW] Frame Skip every 8 seconds Empty Re: [OPEN LOW] Frame Skip every 8 seconds

on Tue Sep 24, 2019 1:10 pm
vantablack3d wrote:Hello,

I have an odd issue that has arisen recently. I have been away from the game for a while and have come back after learning of the rotate camera patch and upcoming changes to manual patient care so spun the game up again to find that every 8 seconds, it seems to "skip" a frame. I can watch people walking down the sidewalk and every 8 seconds without fail, they will appear to freeze for a nano second.

This is happening on both my PC and laptop, both of which I have never seen this previously. There are no mods present.

I'm unsure what other type of information I can provide but please let me know if I can supply anything that may assist in troubleshooting this as it's unplayable with that constant skip.

Thanks.

Hi, from the description this looks most likely to be related to memory garbage collection, which is a part of memory management in C#/Unity - generally shouldn't be really that noticeable though.
We also made some optimizations related to memory usage in the last patch, so hopefully it has improved a bit on your side too.
If you'd like to, you can send us the log file, if there's for example a hidden error popping up continuously, that can also have some impact on performance and we should be able to find more info there. Cheers!
avatar
vantablack3d
medic
Posts : 2
Reputation : 0
Join date : 2019-09-08

[OPEN LOW] Frame Skip every 8 seconds Empty Re: [OPEN LOW] Frame Skip every 8 seconds

on Thu Sep 26, 2019 3:24 am
Hi Jan,

Happy to provide logs, never know, something might be in there. Can you advise what logs and how I can get them?

Thanks!
jan.oxymoron
jan.oxymoron
developer
Posts : 1288
Reputation : 217
Join date : 2018-03-23

[OPEN LOW] Frame Skip every 8 seconds Empty Re: [OPEN LOW] Frame Skip every 8 seconds

on Thu Sep 26, 2019 9:44 am
vantablack3d wrote:Hi Jan,

Happy to provide logs, never know, something might be in there. Can you advise what logs and how I can get them?

Thanks!

Hi, here are the details about where to find the log file: https://projecthospital.forumotion.com/t717-how-to-report-bugs
It could help if you load the save where the problem was most noticeable and let the game run for a minute before uploading the log. Let's see if we find anything out of the ordinary. Smile
Thanks!
Sponsored content

[OPEN LOW] Frame Skip every 8 seconds Empty Re: [OPEN LOW] Frame Skip every 8 seconds

Back to top
Permissions in this forum:
You cannot reply to topics in this forum