Project Hospital
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Go down
avatar
Maximus
intern
Posts : 3
Reputation : 0
Join date : 2019-08-18

[RESOLVED] Elevator Not Placing Correct When Floor is added Empty [RESOLVED] Elevator Not Placing Correct When Floor is added

Wed Aug 21, 2019 1:21 am
[Im not sure if anyone else is experiencing this but when I have elevators and I build a new floor they are always offset 90 degrees and I have to demolish the elevators and rebuild them 😂 I know it’s only a minor bug but building the elevators each time does cost money.

Many Thanks
Maximus
jan.oxymoron
jan.oxymoron
developer
Posts : 2194
Reputation : 314
Join date : 2018-03-23

[RESOLVED] Elevator Not Placing Correct When Floor is added Empty Re: [RESOLVED] Elevator Not Placing Correct When Floor is added

Wed Aug 21, 2019 9:35 am
Hi, thanks for the report - what version of the game are you playing? This bug has been fixed in 1.1.16587.4, the latest version on Steam/GOG.
Btw as it's related to camera rotation, there's also a workaround - you can switch camera to the original orientation with ambulance drop-off zone on the bottom right before building a new floor.
avatar
Maximus
intern
Posts : 3
Reputation : 0
Join date : 2019-08-18

[RESOLVED] Elevator Not Placing Correct When Floor is added Empty Re: [RESOLVED] Elevator Not Placing Correct When Floor is added

Thu Aug 22, 2019 4:12 am
I was playing on the latest version and as this is not the first time it happened I thought of that workaround and unfortunately it did not work Smile however it way have been an old save so hopefully it all works out.

Many thanks
Shizette
Shizette
intern
Posts : 5
Reputation : 0
Join date : 2019-08-21

[RESOLVED] Elevator Not Placing Correct When Floor is added Empty Re: [RESOLVED] Elevator Not Placing Correct When Floor is added

Thu Aug 22, 2019 4:31 am
I had this happen a few nights ago. Seemed the only elevators not affected were ones that I used an Elevator Planner for - even if the elevator had been placed. Any that did not have the planner, were several tiles away from the original. And, when I went to place the elevator in the correct spot, I received an error message to the effect of - Item is Blocked. It was fixed only by deleting the elevator on the floor beneath and then replacing it. Not sure if it matters or not, but if I remember correctly, with the non-affected elevators, I had forgotten to delete the planner marker. Just plopped an elevator right on top. I"m certain this was after the patch.
jan.oxymoron
jan.oxymoron
developer
Posts : 2194
Reputation : 314
Join date : 2018-03-23

[RESOLVED] Elevator Not Placing Correct When Floor is added Empty Re: [RESOLVED] Elevator Not Placing Correct When Floor is added

Mon Aug 26, 2019 1:29 pm
Shizette wrote:I had this happen a few nights ago. Seemed the only elevators not affected were ones that I used an Elevator Planner for - even if the elevator had been placed.  Any that did not have the planner, were several tiles away from the original. And, when I went to place the elevator in the correct spot, I received an error message to the effect of - Item is Blocked.  It was fixed only by deleting the elevator on the floor beneath and then replacing it. Not sure if it matters or not, but if I remember correctly, with the non-affected elevators, I had forgotten to delete the planner marker. Just plopped an elevator right on top. I"m certain this was after the patch.

Hi, thanks for the update! It looks like there were two different but related bugs:
- adding new floor with rotated camera would cause wrong elevator placement for all elevators (this is the one fixed in last patch)
- building an elevator with rotated camera wouldn't correctly save the 'rotated' position used to copy the elevator when adding floors (I'm testing a fix now, should be ready in the next patch)
Shizette
Shizette
intern
Posts : 5
Reputation : 0
Join date : 2019-08-21

[RESOLVED] Elevator Not Placing Correct When Floor is added Empty Re: [RESOLVED] Elevator Not Placing Correct When Floor is added

Mon Aug 26, 2019 6:55 pm
Thank you. Smile
Sponsored content

[RESOLVED] Elevator Not Placing Correct When Floor is added Empty Re: [RESOLVED] Elevator Not Placing Correct When Floor is added

Back to top
Permissions in this forum:
You cannot reply to topics in this forum