Project Hospital
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Go down
ChaosToasterHH
ChaosToasterHH
resident
Posts : 10
Reputation : 0
Join date : 2020-03-07
Age : 29
Location : Germany

[MODDING] DisplayIndex dont work after last Patch Empty [MODDING] DisplayIndex dont work after last Patch

Fri Mar 13, 2020 1:35 am
Hey Buddys,

i found a Bug with the DisplayIndex (Department Icon Position in the buttom Infobar). In my Mod i have DisplayIndex on 9 but Ingame its on 2. Why?

U can see the File in my Git (File: ModGynoDepartment.xml)
Git: https://gitlab.com/ChaosToasterHH/newdepartments

Thanks for helping Smile

Greets
Tim
jan.oxymoron
jan.oxymoron
developer
Posts : 2196
Reputation : 314
Join date : 2018-03-23

[MODDING] DisplayIndex dont work after last Patch Empty Re: [MODDING] DisplayIndex dont work after last Patch

Fri Mar 13, 2020 11:05 am
Hi, you're right, there has been a change behind the scenes are we're slowly preparing for having more departments in DLCs, the DisplayIndex now has a bigger range. Could you try to set it to let's say 200 for your department?
ChaosToasterHH
ChaosToasterHH
resident
Posts : 10
Reputation : 0
Join date : 2020-03-07
Age : 29
Location : Germany

[MODDING] DisplayIndex dont work after last Patch Empty Re: [MODDING] DisplayIndex dont work after last Patch

Sat Mar 14, 2020 12:15 am
Hey Jan,

Thanks for the info I will try it out tomorrow. Why did you change that at all? You could have simply expanded the sequence of numbers. So far you have 9 departments and all others would be 10, 11, 12 .... u know. It's so complicated to use such high numbers for it.

I would have a great idea for you. If you have planned to bring out more departments anyway, I could help you, because that's exactly what my mod is concerned with. I would like to insert all hospital departments from real life including all diseases symptoms and medication and since I upload the whole thing to git anyway and that is an opensource project you can use it or if you even feel like it we can also work on it together, because i think this game is so awesome that i will definitely do a lot for the community. I have enough ideas as a former paramedic ^^

best regards
Tim
ChaosToasterHH
ChaosToasterHH
resident
Posts : 10
Reputation : 0
Join date : 2020-03-07
Age : 29
Location : Germany

[MODDING] DisplayIndex dont work after last Patch Empty Re: [MODDING] DisplayIndex dont work after last Patch

Sat Mar 14, 2020 1:01 am
jan.oxymoron wrote:Hi, you're right, there has been a change behind the scenes are we're slowly preparing for having more departments in DLCs, the DisplayIndex now has a bigger range. Could you try to set it to let's say 200 for your department?

Display Index works now. I changed it to 90 and it works Smile
jan.oxymoron
jan.oxymoron
developer
Posts : 2196
Reputation : 314
Join date : 2018-03-23

[MODDING] DisplayIndex dont work after last Patch Empty Re: [MODDING] DisplayIndex dont work after last Patch

Mon Mar 16, 2020 10:27 am
Nice, happy to hear it works! Smile Btw - I'd still suggest using a slightly higher number, so we don't clash in case we release new departments in future DLCs. Wink
Sponsored content

[MODDING] DisplayIndex dont work after last Patch Empty Re: [MODDING] DisplayIndex dont work after last Patch

Back to top
Permissions in this forum:
You cannot reply to topics in this forum