Project Hospital
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Go down
avatar
TheTFEF
intern
Posts : 3
Reputation : 0
Join date : 2019-03-16

[RESOLVED] GUI gets stuck on particular floor Empty [RESOLVED] GUI gets stuck on particular floor

Sun Mar 15, 2020 1:39 pm
I haven't been able to figure out how to reproduce this bug, so here goes with a rough transcription of events. I was building an operating room for internal medicine, realized I was building it in the spot I'd 'designated' as the operating room for orthopedics' use. I switched through several different departments to verify where I'd put their placements. At some point when I unpaused and went to change to the first floor, the GUI was stuck showing the maintenance screen on the second floor with the walls cutaway to show the first floor, as shown in the screenshot below:

[RESOLVED] GUI gets stuck on particular floor UaSH3Hv

I was still able to copy and paste a trauma center on the first floor, despite the GUI being stuck showing the second floor. I tried switching between different wall cutaway modes to see if it would have an effect, but it didn't aside from working as intended on the first floor. Moving floors back up to my second floor worked fine, with the wall cutaway going back to solid on the first floor.

[RESOLVED] GUI gets stuck on particular floor NpATwwS

I've attached my save file and log file (for what it's worth, this is the same map from my previous 'GUI stuck' post).

Edit: So I've discovered this bug seems to permanently affect the map itself, with some miscellaneous strange behavior. For example, when rotating, the foundations appears to move, as seen below.

[RESOLVED] GUI gets stuck on particular floor S4wKgfR
jan.oxymoron
jan.oxymoron
developer
Posts : 2308
Reputation : 334
Join date : 2018-03-23

[RESOLVED] GUI gets stuck on particular floor Empty Re: [RESOLVED] GUI gets stuck on particular floor

Mon Mar 16, 2020 10:13 am
Hi, thanks for the detailed report! I can see the problem when I open the save, but it seems to be caused by an earlier error - somehow a stretcher got deleted while being reserved or used to transport a patient.

Could you try the attached save? Everything should be working again there and we'll be testing the code hotfix I used so we can include it in the next patch.

Btw - if you remember anything specific regarding building and stretchers, let me know!
Back to top
Permissions in this forum:
You cannot reply to topics in this forum